Mailosaur UI is experiencing degraded performance
Incident Report for Mailosaur
Resolved
This issue was resolved.
Posted Mar 12, 2024 - 16:15 GMT
Identified
We are aware of an issue, related to our support chat functionality, which is causing the Mailosaur UI to be slow to load. Our team is working on a fix for this right now and we hope to have a resolution very quickly.
Posted Mar 12, 2024 - 15:50 GMT
This incident affected: App.