Intermittent connectivity issues for SMTP and POP3
Incident Report for Mailosaur
Resolved
This incident is now closed following a solution implemented by Google.
Posted Feb 06, 2024 - 18:29 GMT
Monitoring
Services are returning to normal for all customers. We will continue to monitor for the next few hours.
Posted Feb 06, 2024 - 18:01 GMT
Update
Mitigation work is currently underway by our Google's engineering team. We do not have an ETA for mitigation at this point. We will provide an update within the next hour.
Posted Feb 06, 2024 - 17:38 GMT
Identified
Google Cloud Networking have confirmed that there is a known issue with increased network latency which is causing issues with SMTP/POP3 connections from outside Europe. Google have confirmed their networking team is actively investigating this issue and attempting to fix ASAP.
Posted Feb 06, 2024 - 17:26 GMT
Update
The issues impacting SMTP and POP3 for some customers only relate to connections outside of Europe. Our team believes this issues is related to Google Cloud Platform network load balancing, but we are still investigating at this time.

The nature of SMTP means that emails will automatically be retried and arrive in most cases, but you may see delays in arrival.
Posted Feb 06, 2024 - 16:40 GMT
Investigating
We are aware of an issue impacting come clients connecting via SMTP and POP3. This is being actively investigated, we will update as soon as possible.
Posted Feb 06, 2024 - 15:01 GMT
This incident affected: SMTP (SMTP (25), SMTP (2525), SMTP (587), SMTP (25) with STARTTLS, SMTP (2525) with STARTTLS, SMTP (587) with STARTTLS) and POP3 (POP3 (110), POP3 (995)).