Some customers unable to forward emails

Incident Report for Mailosaur

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 11:52 BST

Monitoring

We're aware of an issue affecting some customers who are attempting to send emails to external addresses.

As a result of a false-positive inclusion of one of our IP addresses in a blocklist, connections to some mail services are being rejected. The IP in question has since been removed from the list, but it may take several hours for this to propagate to other mail services.

We are continuing to monitor this issue and will update when we're comfortable that this has been fully resolved.
Posted Aug 11, 2025 - 11:10 BST
This incident affected: SMTP (SMTP (25), SMTP (2525), SMTP (587), SMTP (25) with STARTTLS, SMTP (2525) with STARTTLS, SMTP (587) with STARTTLS).