Downtime

Incident Report for Mailosaur

Resolved

Please accept our apologies for the downtime. Our services should be back to normal again.
Thanks.
Posted Sep 09, 2017 - 11:17 BST

Identified

We are currently experiencing performance issues and are working hard on resuming services as before.
Thanks for your patience.
Posted Sep 09, 2017 - 10:54 BST