SMTP service
Incident Report for Mailosaur
Resolved
Performance has restored to normal. We will continue monitoring the situation.
Posted Jun 22, 2017 - 17:21 BST
Investigating
We have some reports of SMTP connections timing out, we are investigating this issue now.
Posted Jun 22, 2017 - 17:10 BST