Website offline
Incident Report for Mailosaur
Resolved
Our website is back to normal operation.
Posted May 20, 2017 - 04:49 BST
Identified
Our website is currently offline - the Mailosaur service itself is unaffected.

We are aware of the cause (a private networking issue) and will be back online within the next 1-2 hours
Posted May 20, 2017 - 02:30 BST